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1  Introduction. 
 
1.1  What is AutoCAD? 
 
AutoCAD is a software package used for draughting and designing almost anything you wish.  The 
software has evolved massively over the years and now offers various ‘themed’ versions catering 
for the specific requirements of different engineering disciplines, such as mechanical engineering, 
civil engineering and architecture. 
 
Basically AutoCAD provides a 3D space (model space) in which you construct or draw your 
design.  It provides drawing layout tools which enable you to prepare and plot conventional 2D 
drawings of your model.  More recent versions also include advanced rendering tools, enabling 
you to create photo-realistic images of your design. 
 
 
1.2  The interface. 
 
Standard Windows type command buttons, pull down menus etc. are provided to use AutoCAD.    
 
One strong feature of AutoCAD is the continued support of its command line.  Any function or 
command you can give AutoCAD can be given by typing in the appropriate command on the 
screen.  AutoCAD supports legacy commands, from previous versions, so learning to use 
AutoCAD through the command line means you should be able to use any subsequent or previous 
releases of the software without getting lost in the menu systems.   
 
This manual will encourage you to use the command line but may also involve use of tool bars and 
pull down menus. 
 
 
1.3  Saving your AutoCAD work. 
 
You are responsible for the safe keeping of your work with AutoCAD.  Work saved on your 
network U:\ drive is safe, but the drive is limited in storage capacity.  You may wish to use other 
removable media such as a USB flash stick (pen drive). 
 
Get into the habit of creating a folder for each project. 
 
When you save work, AutoCAD will create a *.dwg file and a *.bak file of your work.  The *.bak file 
is a backup copy of the *.dwg file. 
 
 
1.4  About the 2D tutorial. 
 
As an introduction to the basics of using AutoCAD in 2D you are presented with this practical 
tutorial.    
 
You will be introduced to a method of creating a projection drawing of a building in 2D and then 
presenting that drawing on an A3 formatted sheet.  Once you are comfortable with these basic 
tools you are encouraged to experiment yourself and then to move on to the 3D tutorial. 



2  AutoCAD - Creating a new drawing. 
 
2.1  Introduction. 
 
In this section you will use AutoCAD to create and set up a new drawing file.  You will also 
become familiar with the toolbars, menus and command line. 
 
 
2.2  Activating AutoCAD. 
 
Only certain rooms contain computers with access to AutoCAD.  You will find a shortcut installed 
under the University Software list, under A for AutoDesk.  Click the appropriate shortcut and wait 
for the program to load. Video clips will require use of headphones. 
 
 
2.3  The AutoCAD display screen. 
 
When AutoCAD has successfully loaded you should have the window similar to that shown below: 
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Model/Layout tabs, which may need to be 
revealed – right click one of the buttons shown in 
red shape here and click Display……...

Pulldown menus
Tool bars.

Command line.



2.4  Setting up a new drawing. 
 
New commands used in this section: 
close, new, saveas, units, limits, grid, snap, and save. 
 
 
2.4.1  Creating a new drawing file. 
 
To make a space to store your work, create a new folder called     acad_examples 
 
This folder could be on the U:\ drive or any other suitable location of your choice. 
 
To start working with a fresh drawing, close the drawing file that AutoCAD opened with: 
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Command: close 
Pull down menu: File > Close 

Remember that you can use 
either of these input 
methods... or the toolbar 
buttons. 

 
Create a new drawing using the acad.dwt template: 
 
Command:  new    Enter (Only if command line is available) 
Pull down menu: File > New... 
 
Select the acadiso.dwt template (which is metric) and click Open. 
 
Save this drawing to your acad_examples folder calling it template_mm. 
 
Command:  saveas   Enter 
Pull down menu: File > Save As... 
 
You now have a new drawing named and saved.  Next job is drawing set up. 
 
 
2.4.2  Drawing units setup. 
 
The AutoCAD drawing units can be defined by you. 
 
Command:  units    Enter 
Pull down menu: Format > Drawing Setup... 
 
You should now see the Drawing Setup window. As we will be drawing buildings in the region of 
thousands of millimeters in length, set the units to Millimeters, and the precisions of Length, Area 
and Volume to 0. 
 
Click OK to enter these changes and OK to confirm scale changes, if it appears. 
 
Video demo: Units, limits and grid > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/units_limits_grid.wmv 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/units_limits_grid.wmv


2.4.3  Drawing limits setup. 
 
AutoCAD likes to know the overall size limits of the model.  For this example a square area of 
10000 mm by 10000 mm will be appropriate.  To set this up: 
 
Command:   limits    Enter 
Pull down menu:  Format > Drawing Limits  (then type in command line) 
 
In the command line observe the text in brackets, <0,0>.  This is the default value which will be 
entered if you press return or...  right mouse button click then click on Enter. 
 
This is acceptable, so enter.  Next type in the required x and y co-ordinates of the top right corner 
of the required drawing limit: 
 
10000,10000 and enter. 
 
 
2.4.4  Drawing grid and snap setup. 
 
To help with draughting, a grid can be displayed over the area defined by the limits of the drawing.  
To define the spacing of the grid: 
 
Command:   grid    Enter 
Pull down menu:  Format > Draughting Settings... 
 
For this project, let’s use a grid spacing of 250 mm.  Enter these values, either on the command 
line or in the Draughting Settings window in the Grid value boxes. 
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To display the grid, or to activate snap, use the buttons along the bottom of the screen or the 
command line grid command. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Video demo: Coordinates > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/coordinates.wmv 

Click to display the grid. 
<10000,10000> 

There may be a 
DUCS button here. 

250mm 
grid 
spacing. 

<0,0> 



To define the snap settings: 
 
Command:   snap    Enter 
Pull down menu:  Format > Draughting Settings... 
 
Video demo: Snap > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/snap.wmv 
 
For this project make the snap spacing 250 mm, the same as the grid.  Enter these values, either 
on the command line or in the Draughting Settings window in the Snap value boxes. 
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To zoom the display to view the extremes (extents) of the drawing limits: 
 
Toolbar button:  
 
 
 
Command: z  <Return> to run the zoom command, then enter    a   <Return> for zooming 

to all objects in the drawing. 
 
 
 
2.5  Toolbar setup. 
 
Move the pointer over any toolbar and right hand mouse button 
click and select ADT > .  From this selection box you can 
define which toolbars to display on the screen.  
Experience has shown that these selections are useful. 
 
Particularly Modify & Zoom...... 
 
You can drag the resulting button windows to the side or top of 
the display. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Save the file: 
 
Pull down menu: File > Save 
Command:  save    Enter 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/snap.wmv


3  AutoCAD – Lines and layers. 
 
3.1  Introduction. 
 
This section will introduce you to some basic fundamental draughting techniques with AutoCAD by 
leading you through a practical drawing tutorial.  You will work with entities and layers to create 
the 2D 3rd angle orthographic projection drawing show below. 
 
 
 

 
 
 
3.2  Pre-requisites. 
 
You should have completed section:   2 AutoCAD - Creating a new drawing. 
 
...and have the  template_mm.dwg  file ready to open.  
 
 
3.3  Setting up the drawing. 
 
New commands used in this section: the F9 key and z (for zoom). 
 
Start AutoCAD and open the template_mm.dwg  file. 
 
Save the file. 
Command:    saveas   Enter  sports_hall.dwg 
 
Check the units set up  
Command:    units    Enter  mm, precision 0 
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We will assume that for this drawing a rectangular drawing area of 50m by 30m is required.  This 
is set using the drawing limits. 
 
Set the limits. 
Command:   limits     Enter     
Accept default, <0,0>      Enter 

50000, 30000  Enter 
Set the grid. 
Command:    grid    Enter 
to a spacing of:   1000    Enter 
 
Set the snap. 
Command:    snap    Enter 
to a spacing of:   500    Enter 
 
Zoom to all objects in drawing:   
Command:    z      Enter 
all objects in the drawing a     Enter 
 

 

You should see the grid as shown here. 

 
  The F9 key: 

 
Move the pointer around the display.  Does it appear to jump around in intervals of 500 
units?  (Hint:  Look in the bottom left hand corner to see the display of the pointers current 
coordinates.)   
If it does, your snap function is ON.  At any moment in time when you are drawing you can 
toggle the snap ON or OFF using the F9 key.  Try it.  Move the pointer around whilst 
repeatedly pressing the F9 key. 
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3.4  Lines. 
 
3.4.1  Using absolute & relative coordinates. 
 
New commands used in this section: line, @ (for relative coords), the Esc key. 
 
Video demo: Absolute & relative coordinates > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/abs-rel_coordinates.wmv 
 
You may find it easier to draw with these buttons clicked off: 

POLAR  OTRACK  DUCS  DYN 
These are drawing tools which can get in the way when learning the basics. 
 
We will now start drawing!  The line command allows you to create straight lines, one after the 
other (chained).  You specify the first point and as one end of the first line, then the next point 
which as the end point of the first line and... the start point of the second line, and so on. 
 
First we will use an absolute coordinate to specify the start point of the line. 
 
Command:     line    Enter 
Specify these coordinates:   19000,12000    Enter 
 
(This creates the line start point at  x = 19000, y = 12000.) 
 

 Absolute coordinates are measured from the origin, x=0, y=0, or <0, 0>. 
 
Now specify the other end point of the line (next point) using relative coordinates. 
 
Specify these coordinates:   @10000,0     Enter 
 

 Relative coordinates are specified using the @ symbol.  A relative coordinate is measured 
in the x and y directions, from the last point created.   
 
Here we have drawn a line 10000mm along the x axis and 0 mm up the y axis, measured from the 
point <19000, 12000>. 
 
 

                      

Start point, using absolute 
coordinates, at:  
x=19000, y=12000 

End point of the line 
specified with a relative 
coordinate: 
@10000,0 
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http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/abs-rel_coordinates.wmv


To stop the line command, simply use the Esc key.  The Esc key will always cancel or finish any 
running command.  This is now a completed line. Relative and absolute coordinates have their 
use, particularly relative coordinates, when moving objects, etc.  There are other ways of 
specifying positions in AutoCAD.  Read on... 
 
3.4.2  Using snap. 
 
New commands used in this section: the F7 key, coords.  
 
We will draw some more lines using the grid and snap as guides for positioning the pointer along 
with absolute coordinates.  We will also use the coordinate display in the bottom left of the screen 
to confirm the position of the pointer. 
 
Press Esc just to cancel any commands still running. 
 
Ensure grid is on:    F7 key toggles the grid display. 
Zoom to all objects:  Command:  z    Enter 
      a   Enter 
 
Move pointer around the screen to see if snap is ON of OFF.  Use F9 key to ensure snap is ON.  
Observe the coordinate display in the bottom left of the screen.  The pointer should be jumping in 
steps of 500 units.   
 
Start drawing the next line: 
 
Command:     line    Enter 
Specify these coordinates:   21000,12000    Enter 
 
Now move pointer around, observing the coordinate display. 
 

It should be displaying the absolute x & y coordinates of the pointer.   
 
 
 
 

 Just for information:  
 
The coords command controls how coordinates are updated 
on the status line.  It can be controlled by setting its value as 
specified below: 

 
0  Coordinate display is updated as you specify points 

with the pointing device.  
1  Display of absolute coordinates is updated 

continuously. 
2  Display of absolute coordinates is updated 

continuously, and distance and angle from last point 
are displayed when a distance or angle is requested. 

 

 
 
 
 
 
 
 
 
 
 
 
 
Back to drawing the line.  After the first (start) point, move the pointer around and snap to and click 
on the position: 
 
21000, 20500 
 
Esc or (right mouse button Enter) to finish the line. 
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To draw another line click the right mouse button and select Repeat LINE, or enter line on the 
command line. 
 
Use absolute coordinates again for the start point: 
 
27000, 12000   Enter 
After this, move the pointer around and snap to and click on the position: 
 
27000, 20500 
 
Esc to finish the line 
 
Next we will draw a freeform curve (spline) to show the roof shape. 
 
 
3.4.3  Drawing splines. 
 
New commands used in this section: spline, erase 
 
Video demo: Splines > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/splines.wmv 
 
A spline is a curve, or line, defined with several control points and end point tangents.  The best 
way to learn how to create them is to have a go. 
 
F9 to turn snap OFF.  This allows us to freely pick positions with the pointer. 
 
Zoom to all objects:  Command:  z    Enter 
      a   Enter 
 
Zoom to a window:  Command:  z    Enter 
      w   Enter 
 
Left mouse click to start dragging a window over the lines drawn, left mouse click again to zoom. 
 
Run the spline command:  spline 
 
Click four random positions on the screen to define the main curve, maybe as shown here: 
 
Press Enter (or right mouse button > 
Enter) to define the direction of the 
tangent of the start of the spline.  
 
Click somewhere here: 
 
(Observe how the curve moves as you 
change the tangent.) 
 
Then for the end tangent click down  
somewhere here: 
Draw four more of these splines, for 
practise. 
 
To delete, remove or erase entities you have created you can use the erase command. 
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http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/splines.wmv


 
Command:     erase    Enter 
 
Select the splines you have just drawn and   Enter  (or right mouse button) to the execute erase. 
 

 Whenever prompted to select objects, AutoCAD will expect you to either click on entities in 
the drawing or enter an extra command on the command line, such as all, which selects all 
objects in the drawing.  Once selected, you have to press enter to confirm the selection.  For more 
details refer to select in the Help menu. 
 
Now draw the proper roof spline, like this: 
 
Using absolute coordinates, make sure the top 
end is at (x, y):  
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29000, 19000 
 
Click, with snap OFF, to define four 
intermediate control points as shown here, and 
finally make the lower end point at absolute 
coordinate (x, y): 

(29000, 19000) 

(19000, 16000) 
19000, 16000 
 
Remember to toggle the snap ON/OFF, as required, using the F9 key. 
 
 
3.4.4  Trimming. 
 
New commands used in this section: trim 
 
Video demo: Trimming & extending > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/trim_extend.wmv 
 
Now we will trim the two vertical wall lines back to the roof spline using the trim command. 
 
The trim command requires two groups of selections.  The first group defines the entities you 
wish to use to trim up to (the cutting edges), the second is the portion of each line you actually 
wish to be removed, or trimmed. 
 
So for this example we will first select the roof spline as the cutting edge, Enter that selection, 
then click on the two upper parts of the vertical lines representing the walls to trim them. 
 
So...  command:    trim    Enter 
 
Click on the roof spline:         Enter or right button 
 
Now click on part of each wall line you wish to remove...    and it should trim for you. 
Esc to finish. 
 

 Note that often the right mouse button performs the same function as the Return 
or Enter  key. 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/trim_extend.wmv


3.4.5  Offsetting lines. 
 
New commands used in this section: offset, extend. 
 
The offset command is a very useful one to know.  It allows us to effectively copy a line and 
project or translate it a specified distance from the original. 
 
Video demo: Offsetting > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/offset.wmv 
 
This sports hall  project calls for the roof to be exactly 400mm proud of the walls.  To draw this we 
can offset the walls by 400mm exactly, and then use these temporary lines as cutting edges to 
trim the roof spline back to.  We erase them once the roof has been trimmed. 
 
So, to offset each wall by 400mm: 
 
Command:    offset    Enter 
 
The first thing needed is the distance to offset, so enter the value of 400: 
 
     400    Enter 
 
Now simply click on the wall you wish to offset and then click in the area on the side of it to offset 
to.  The new line should appear.   
 
The offset command continues to run, now offsetting anything you select until you press Esc or the 
right mouse button.  Offset the other wall as well and then Esc. 
 

  You can offset circles, rectangles, polylines, splines, etc. 
 
Extending lines: 
In order to trim the roof back to these new temporary lines, they have to either touch or intersect 
the line to be trimmed.  To achieve this, the right hand wall line will need to be extended up to the 
roof.  To do this we use the extend command, which works just like the trim command.  Run the 
extend command and experiment!  Remember to select first the line to extend up to,  Enter, 
then select the lines to extend. 
 
Now use these two new offset lines as cutting edges to trim the roof to.  Then erase them. 
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Wall offset 
through a distance 
of 400mm. 

Line needs to be 
extended up to the 
roof before 
trimming the roof.

Wall offset 
through a distance 
of 400mm. 

Trim this portion of 
the roof back to the 
offset wall. Trim this portion of the 

roof back to the offset 
wall. 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/offset.wmv


You should now have a neat roof, with an overhang of exactly 400mm, like this. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3.4.5.1  Grabs. 
 
All entities you create in AutoCAD have grabs.  These are points on geometry which can be easily 
clicked on and dragged to relocate. 
 
Press Esc just to cancel any previous command and click on the roof spline to reveal its grabs.. 
 
Give the roof a more interesting shape by moving the control point grabs, the ones between the 
ends, around, not the end points. 
 
You will need to practice using trim and extend on the walls to make them match the roof line. 
 
 
 
 
 
 
 
 

Extend this 
line up to the 
roof. 

 
 

Trim this back 
to the roof. 
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3.4.6  Using object snap. 
 
New commands used in this section:  osnap, the F3 key. 
 
So far, when drawing, the pointer position has been controlled using: 
 

• coordinates, actually entered in on the command line, both relative and absolute x and y 
values. 

• snap, which forces the pointer to jump or snap to preset intervals.  
(F9 key, remember?) 

 
Another very useful facility for placement of the pointer is called object snap.  Object snap allows 
you to snap with total mathematical accuracy to particular features of an object, such as the end 
point or midpoint of a line.   
 
Video demo: Object snap > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/osnap.wmv 
 
Object snap can be toggled ON/OFF any time you like using the F3 key. 
 
Object snap can be set up by running the osnap command.  Have a look: 
 
Command:    osnap    Enter 
 
The resulting window is fairly self explanatory.  Select all or any of the options, any time you like 
when drawing. 
 
Now we will develop the roof detail.  The roof is 300mm thick, and will be drawn by offsetting the 
existing roof spline by 300mm.  These two splines will then be joined at their ends with straight 
lines, using object snap. 
 
First... offset the roof spline by 300mm. 
 
Command:    offset    Enter 
 
The first thing needed is the distance to offset, so enter the value of 300: 
 
     300    Enter 
 
Now simply click on the roof spline and then click somewhere above it to perform the offset.  The 
new line should appear.   
 
Now is the time to use object snap.  We will fill in the end sections of the roof.  Firstly zoom in to 
the area we will be working on by zooming to a window:   
 
Command:     z    Enter 
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     w   Enter 
 
Left mouse click to start dragging a window over the  
area shown here, left mouse click again to zoom. 
 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/osnap.wmv


Now use F3 to ensure object snap is on.  Then start drawing the line. 
 
Command:    line    Enter 
 
To define the start point of the line move the pointer 
over the end of one of the splines and look for the 
Endpoint flag to be raised by object snap, then click. 
Repeat this for the other end of the line.  Esc to finish. 
 
Draw a similar line for the other side of the roof. 

Other end 
of line. 

 
Save the work. 
 
 
 
 
3.4.7  Layers. 
 
New commands used in this section:  la (layer) 
 
We now have a simple outline of one of the side views of the sports hall.  We will use this view as 
a starting point for creating the other orthographic projection views.   
 
We will create construction lines to help us.  We will also learn about use of layers to help control 
the viewing of our work. 
 
As soon as we start to create construction lines the drawing starts to become messy and hard to 
read.  Layers are, in a way, like sheets of tracing paper.  They can actually be turned off so that 
they cannot be seen.  (They can also be locked so that they can be seen but not changed.) 
 
Every type of object should really have its own layer.  For example, construction lines would have 
their own layer, which can be turned on or off as required.   
 
When you create a line, it will be placed on the layer that is current.  This line will, by default, 
assume the linetype and colour set by the layer.  This is the most efficient way of controlling what 
a line looks like, by the properties of the layer it is on.   
 
Video demo: Layers > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/layers.wmv 
 
 
3.4.7.1 Creating a new layer. 
 
To create a new layer, first open up the layer manager window: 
 
Command:    la    Enter 
 
From the Layer Manager toolbar click on the New Layer button: 
 
Enter the new layer name: 
 
construction_lines 
 
Double click on the colour square to select a colour, perhaps a pale green. 
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In the Linetype column double click on the linetype description (it may currently be ‘Continuous’). 
 
If you cannot see the PHANTOM2 line type click on the Load button in the Select Linetype 
window. In the resulting Load or Reselect Linetypes window scroll down and select the 
PHANTOM2 type.  Click on OK.  This loads the line pattern in to the drawing. 
 
Now select the new linetype for this layer by clicking on PHANTOM2 in the Select Linetype 
window and click on OK.   
 
Note the addition of the new layer in the Layer Manager window.   
 
Click on OK again to return to drawing. 
 
Before we start creating construction lines, make the construction_lines layer current: 
 
In the Layer 
Properties tool bar, pull 
down the selection menu 
and click on the 
construction_lines layer 
name.  This should make it 
the current ‘live’ layer.  
 
It should show in the window, indicating that it is the current layer.  Anything your draw now will go 
on to that layer and adopt that layers properties, such as colour and linetype. 
 
3.4.7.2 Turning a layer off. 
 
In the Layer Properties tool bar, pull down the selection menu and click on the light bulb next to 
the layer you wish to turn off.  Click in the display screen somewhere, and the layer will be turned 
off.  If that layer is the current layer you will be told so.  If you find you can’t see lines you draw at 
any stage, just check to make sure that the current layer is on! 
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3.4.8  Construction lines and linetype scale. 
 
New commands used in this section:  xline and ltscale   
 
We will now create some construction lines.  Construction lines are the same as lines but with 
infinite length.  We use then for projecting locations, to help with building up a drawing.  They are 
created using the xline command.  Amongst other options, you can create horizontal and vertical 
lines. 
 
Command:    xline    Enter 
     h    Enter 
 
This sets us up for drawing horizontal construction lines.  Using object snap, check it’s on using 
F3, and click on roof and ground endpoints to create these lines: 

 
Note the appearance of the lines.  They should appear according to how the layer was set up, i.e. 
in this case be the ‘one long and two short’ dash PHANTOM2 type linestyle.   
 

  AutoCAD tends to display linetype patterns by scaling them relative to a drawing 
unit.  A solid continuous line will be displayed if the scale of the linetype is too small or too big to 
be clearly shown.  For example, if your drawing units are in mm, the linetype pattern will repeat 
every couple of mm.  If however your drawing units are meters, the linetype pattern will repeat 
every couple of meters.  Also check out the Scale tab in the Format > Drawing Setup… window, 
this can affect the ltscale as well. 
 
You can change the scale that all lines are displayed within the drawing using the LTSCALE 
command, which means Line Type Scale.  The command line is not case sensitive, so either 
upper or lower case characters can be used.  The default value of the LTSCALE is usually 1.  Try 
a linetype scale value of 1000:  
 
Command:    LTSCALE   Enter 
     1000    Enter 
 
Observe how the line appearance may change.  Change the value of ltscale again if you like, to 
suit your needs.  This value affects the linetypes of all lines drawn, it is said to be applied ‘globally’. 
 
Video demo: Linetype scale > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/ltscale.wmv 
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Now we will create the FRONT view of the sports hall. 
 
We will end up drawing the front view using the intersection of construction lines as object snap 
references. 
 
Firstly, use vertical construction lines to define the size and position of the new view.  The building 
incidentally is 8000mm wide. 
 
Command:    xline    Enter 
     v    Enter 
 
Use snap, referring to the coordinate display, position the vertical construction line anywhere 
where x=36000. 
 
Esc to cancel, and offset this line 8000mm to the right. 
 
Then offset each of these new lines 400mm outside the building to act as guides for the 400mm 
roof protrusion. 

 

X = 36000
 
 
 
Using these new construction lines, and object snap, we can now start drawing the FRONT view.   
 
First we need to think about layers.  Create a new layer called outlines (refer to the section on 
layers), make the colour a light blue and ensure the linetype is continuous.  
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3.4.9  Properties of objects and changing layers. 
 
New commands used in this section:  properties. 
 
An object is anything created in the drawing, such as a line, circle, dimension, text, spline, etc.  
Each object has its own set of properties.  You can change any of these properties whenever you 
like.  To access an objects properties you simply double click on it. 
 
Double click on one of the construction lines.  You should get a properties window like this one: 
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Select 
Objects 
button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Here is where you 
can change the 
layer that the 
object is on. 

This indicates the 
type of object 
selected. 

Note that some 
properties are 
ByLayer, meaning 
that they are 
governed by the 
setup of the layer 
the object is on. 

 
 
 
 
 
 
 
 
Now click on the Select Objects button and drag a window top left to bottom right over the original 
side view lines.  Enter to finalise your selection.  The properties window should now indicate that 
7 lines are selected.  Change the layer that these lines reside upon by  clicking on the 0 in the 
layer window and selecting the outlines layer. 
 

 Dragging the selection window from left to right only selects objects inside the window 
perimeter.  Dragging the selection window from right to left selects objects which the 
perimeter intersects with as well as those inside. 

 
These lines should now be on the outlines layer and they should have changed colour to dark 
blue. 
 
Click on the X to close the properties window. 
 



Make the outlines layer current (layers) and draw the front view outline, remembering to use the 
OSNAP (right click) Settings > intersection setting and OSNAP on (F3).  
 
Turn off the construction_lines layer and you should see the LEFT SIDE and FRONT views as 
shown here: 
 

 
 
3.4.10  Moving objects. 
 
New commands used in this section:  move and mirror 
 
These views are not in the best position within the limits of the drawing for creating the other 
views.  Using the move command we will relocate everything drawn so far, including the 
construction lines. 
 
Ensure all layers are ON and that object snap (F3) and snap (f9) are both ON. 
 
The move command is executed in two stages.  The first requires selection of the objects to be 
moved.  The second requires a point to be specified which will be used to re-locate the objects. 
 
Zoom out to see all: 
Command:    z    Enter 
     a    Enter 
 
Start the move: 
Command:    move    Enter 
     all    Enter  (selects everything) 
         Enter  (enters selections) 
 
Using the object snap facility specify the base point by clicking on the left hand endpoint of the 
ground line, in the LEFT SIDE view.  Move the pointer now and observe that all selected objects 
move with it.  Next enter the second point (destination): 
 
4000, 4000 
 
The objects have now been moved.  Move can be used on any object.  
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Create the other views, PLAN and RIGHT VIEW, in 3rd angle orthographic projection.  Make use of 
construction lines and the commands used so far. 
 

 

Create as many 
construction lines as 
you need. 

xline  Enter 
a  Enter 
- 45  Enter 

FRONT view 
is here.

LEFT SIDE 
view is here.

 
Add hidden detail where appropriate; remember to create a layer called hidden_detail for the 
hidden detail, using appropriate linetype (DASH perhaps) and 

colour.   

Outline views should 
look like this, with the 
construction_lines 
layer turned off. 

RIGHT SIDE 
view can be 
mirrored from 
LEFT SIDE 
view. 

 
Always think about how you can save time when drawing.  For example, at this stage the left and 
right views are simply mirror images of each other, so rather than drawing the right view, simply 
use the mirror command to reflect it.  With snap ON it is easy to select the first and second points 
down the middle of the FRONT view for the mirror line. 
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3.5  Hatching. 
 
New commands used in this section:  bhatch 
 
 
Hatching is usually applied in construction drawings 
to specify the use of a certain type of material.  
Hatching is usually applied to detail drawings 
to clarify cross sections of complicated areas of a 
structure or assembly of parts.   Hatching may also 
be used on layouts to describe how surfaces 
are finished.  For guidance on the use of standard 
hatching patterns refer to the course notes for your 
module and of course BS 8888. 
 
For this example we will indicate that the ground 
this building is on is earth.  The hatching pattern 
for earth is as shown here: 
 
We will create a hatch region on the front view of 
the drawing. 
 
Create two new layers, calling them hatch and hatch_boundary.  Give them colours of your 
choice. 
 
Draw a spline, using object snap to snap to the existing ground line, to define the boundary of the 
hatch.  Put this line on the hatch_boundary layer, through its properties 

perhaps?    
Use the bhatch command to create a hatch pattern. 
 
Command:    bhatch    Enter 
 
In the resulting Boundary Hatch and Fill window click on the browse button for the pattern and 
select the earth pattern.  Set the angle to 45°. Experiment with the scale setting, 100 to 1000 
perhaps.  Either click on the Add pick points button and click inside the region you want hatched 
or use the Add select objects button and click on the lines you want to use to form the boundary 
of the hatching.  Click on preview and follow the command line instructions.  The hatch pattern 
should fill the spline area.  Put the hatch pattern object on the hatch layer and turn off the 
hatch_boundary layer. 
 
Video demo: Hatching > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/bhatch.wmv 
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4  Repetitive objects. 
 
New commands used in this section:  block, insert, wblock 
 
Reusable objects in AutoCAD are called blocks.  Once defined they are embedded in the drawing 
file, and will always be there for future use.  When a block is inserted it can be scaled in x, y or 
both, rotated or exploded (exploding breaks a complex object down into its individual elements 
such as lines and arcs). 
 
Two things to think about when creating blocks: 
 

• Blocks created on layer 0 will assume the layer properties any layer they are inserted on at 
a later date. 

 
• Blocks require an insertion point, which is used as the base point reference when inserting. 

 
For this drawing we will draw a couple of windows, make a block out of each and then insert 
multiple instances of them. 
 
 
4.1  Creating blocks. 
 
Make sure that layer 0 is the current layer.  Draw these two windows, anywhere in the drawing, 
they will be removed later. 
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Circle 
command, 
diameter 
1000mm, 
offset again 
by 50mm. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Try using the 
rectangle 
command to 
draw the outer 
frame, 
measuring 
1000mm X 
2000mm. 

 
 
 
 
Create the blocks: 
 
Command:    block    Enter 

For the inner 
frame line, 
simply offset 
the rectangle 
by 50mm. 

 
In the Block Definition window enter the name of the block:  window_rectangular 
 
Click on the Select Objects button and select the ‘rectangular window’ objects.  In the Base Point 
section click on the Pick point button and using snap or object snap click on the bottom left of the 
rectangular window.  Click the OK button and the block is defined.  Repeat this for the round 
window, name the block window_round and use the center as the base point. 
 



4.2  Inserting blocks. 
 
We will insert these new window blocks using the insert command.  
 

  Because our two new blocks were created on layer 0, when inserted they will adopt 
the properties of the current layer. 
 
So, create a new layer for the windows, give it a blue colour and make it current. 
 
Run the insert command: 
 
Command:    insert    Enter 
 
In the Insert window the following settings are made and click OK.   
 
 
Then place the block in the 
drawing as required, 
perhaps like below.   
 

   
For multiple insertions you 
could use the copy 
command (with the ‘m for 
multiple’ option) rather than 
inserting the block each 
time. 
 
Complete the other views 
as appropriate.   

 
 
For more practice draw a door on layer 0, 2200mm high.  Make it into a block called door, and 
insert somewhere appropriate.  (Don’t forget to create a new layer for doors.) 
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4.3  Using blocks in other drawings. 
 
You can insert any external AutoCAD drawing as a block into your current drawing.  This, 
incidentally, is how the boarder is placed on the layout paper in section 6.  You can also turn any 
block in your current drawing into an external separate drawing file.  You do this using the wblock 
command (write block). 
 
If you wish to experiment with this command: 
 
Command:    wblock    Enter 
 
...and experiment with the settings. 
 
4.4  Re-defining blocks. 
 
If blocks are not exploded, they are still defined by the block definition saved in the drawing.  If you 
change this block by re-defining it, all instances of it will automatically change as well.   
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If, for example, you wanted to change the rectangular window design in the above example, you 
simply repeat the block creation process using the same name for the block, like this..... 
 
Make layer 0 current.  Redraw the window by inserting the original 
window_rectangular block.  Explode it and offsetting the rectangles by 
100mm, making a smaller window.  Erase the original rectangles.  
 
Use the block command to re-define the window_rectangular block.  Use the 
original corner as the base point. 
 
When the block has been re-defined your 
drawing should show the new smaller 
windows. 

Use original corner as 
base point. 

 
5  Dimensioning and annotation. 
 
New commands used in this section:  dimstyle 
 
We now have a simple layout drawing, showing the Sports Hall design using FRONT, LEFT SIDE, 
RIGHT SIDE & PLAN views created using 3rd angle orthographic projection.  Now we will add 
more information to the drawing such as basic overall dimensions and positions of various 
features such as windows and doors, and descriptions of the views. 
 
5.1  Dimension style and drawing standards. 
 
Dimensioning in AutoCAD is straight forward if you follow a consistent procedure for setting things 
up to begin with.  The appearance or style of dimensions is highly configurable in AutoCAD.   The 
style that should be used is usually specified in the drawing standards required by the client or 
organisation the drawings are being created for.  They will either specify their own standards or 
internationally recognised standards defined by organisations such as BSI, ISO or ANSI.  
 
All drawing conventions in these notes are based on:  
BS 8888 Technical product documentation (TPD) 
BS 1192  Construction drawing practice 
If no standards are referred to when drawing, the two standards above are recommended. 



5.2  Creating a new dimension style. 
 
We will use the default ‘standard’ style, modify it slightly and then save it so it can be used later 
on. 
 
5.2.1  The features of dimensions. 
 
Standard dimensions have particular features which are all configurable in AutoCAD.  Each has its 
own value which can be set in the dimstyle manager window, as you will be shown next.  These 
are some of the features along with the system variable in bold. 
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Extension lines: 
Extend beyond dimension lines. 
dimexe 

Dimension lines: 
Baseline spacing 
dimdli 

 
 
 

Arrow heads: 
Arrow size. 
dimexe 

 
 
 
 

 
 
 
 

Extension lines: 
Offset from origin. 
dimexo  

 



5.2.2  Defining a new dimension style. 
 
To set up the dimension style use the dimstyle command: 
 
Command:    dimstyle    Enter 
 
Note that this uses the ‘standard’ style.  We will now create a new style: 
 
Click on the New... button and in the window enter a name for the style such as sports_hall1. 
 
Have a look at the current set up, click on the Lines and arrows and Text tabs.  Note that the 
sizes of the various features of the dimensions are all too small for our drawing.  We will define the 
sizes of the various dimension features in order to conform to recommendations from BS 8888. 
 
On the Lines and Arrows tab: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Change all of the settings to see what effects they 
have.  Then set them as shown here.  Note that the 
tabs in this window may be structured slightly differently 
on your version of the software, but the same 
parameters will be there somewhere, look for them. 
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On the Text tab: 
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Again, in each window, change 
the settings to see what effects 
they have.   
 
Then set them as shown here. 

On the Fit tab: 
 
Overall scale is 
important.   
 
As we are 
dimensioning in 
model space, 
we will have to 
apply an 
overall scale to 
magnify the 
dimensions. 
 
Dimscale 
command also 
sets this value. 



On the Primary Units tab: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Precision is 
also important, 
and it’s setting 
would depends 
upon overall 
size of objects 
drawn. 

 
 
 
 
 
 
 
 
 
 
 
Once these settings have been defined, click on OK and set this new style to current and close. 
 
5.3  Creating dimensions. 
 
Create a new layer for the dimensions called dimensions and colour it yellow.  Make this new 
layer the current layer. 
 
Bring up the dimension toolbar by right mouse button clicking in an empty area of the top toolbar 
and select ADT > Dimension. 
 
 
 

Linear 

Diameter 

Continue 

Baseline 
Aligned 

Try using these types of 
dimensions to create the 
dimensions shown on the 
next page. 
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Add these dimensions to a side view. (Your dimensions should appear yellow.) 
 
 
 
 
 
 
 
 
 
 

Aligned 

Diameter 
To add the text suffix TYP (which means 
typical), simply double click on the dimension 
to open its properties and edit the text suffix 
entry under Primary Units. 

All other dimensions on 
this view are Linear 

Dimension extension lines should have a gap or offset from their 
point of measurement or origin.  This is to avoid confusion 
between actual drawing geometry and dimension lines.  So... be 
careful what you select using object snap. 
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Next add some dimensions to the front view using the linear and then baseline and continue 
dimension types. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Once created, a dimension can be 
‘single clicked’ on to be 
repositioned using its grabs, or 
‘double clicked’ on to access its 
properties. 

 
 
 
 
 
 
 
 
 
 
 

Continue dimensions also need a 
linear dimension to start them off. 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Baseline dimensions need a linear 
dimension to start them off. 

 
 
5.4  Annotation. 
 
It is often necessary to add text to a drawing.  In this section we will give each view a description 
by adding text, using the mtext command.   
 
Firstly create and make current a layer called text.   
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We will now create a title for the front view.  Run the mtext command: 
 
Command:    mtext    Enter 
 
The mtext command requires that you define a window in which the text will appear.  Follow 
prompts on the command line, dragging a window over where you want the text to appear.   
 
Examine the Text Properties window.  Note how you can select the font type and size, and how 
you can enter the text in the window.  Experiment with these settings.  
 

 Remember that BS 8888 requires that all characters in a drawing must be legible 
and consistent, with consideration being given to the possibility of drawing 
reductions and poorer quality reproductions being made. 

 
No particular style is required, but characters should all be consistent on the same 
drawing, which means using only one font type.  Capital letters are preferred to 
lower case ones. 

 
Size of lettering, according to BS 8888, is given as a minimum height, relating to drawing size, as 
shown below: 
 
Application  Drawing sheet size Min. character height (in mm) 
  
Drawing numbers A0, A1, A2 & A3  7 
Titles, etc.  A4    5 
 
Dimensions & A0    3.5 
Notes.   A1, A2, A3 & A4  2.5 
 
These sizes refer to the actual sizes on the printed paper copies of the drawing.  As we are 
working to full scale in model space we will need to use a text height of something like 500mm.  As 
the drawing model will all be reduced to fit on to an A3 sheet later on, this text should be about the 
right size.   
 
Remember also that the properties of the text can be changed after you have created it. 
 
Once you are familiar with the mtext command, create the other view titles, as shown on the 
target drawing on page 3. 
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6  AutoCAD – Presenting your drawing. 
 
 
6.1  Introduction. 
 
Once you have completed your drawing work in model space you usually need to present the 
information.  It should be layed out on correctly formatted drawing sheets, with title blocks, 
boarders, company logos, etc.  AutoCAD provides this function through the use of layouts.   
 
Layouts can be thought of as sheets of drawing paper which can be added to the drawing file, as 
many as required.  (AutoCAD files have default layout tabs next to the model tab at the bottom of 
the display.)   
 
On a layout sheet AutoCAD shows you the model through a view port.  You can create and size 
as many view ports as you like.  Each view port can offer a different view point, pan and zoom set 
up, giving you total freedom to create any view you like. 
 
The layout also allows you draw straight on to the paper itself, for displaying a title block and 
boarder for example. 
 
In this section you will create a new layout and set up an A3 drawing of the Sports_hall drawing 
using a standard boarder format. 
 
Video demo: Model space & paper space > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/paperspace.wmv 
 
6.2  Pre-requisites. 
 
You must have completed the previous sections or have a drawing in model space. 
 
You must have the drawing boarder file to hand, UoP_A3.dwg, downloaded from the module 
resource web page. 
 
6.3  How to prepare a blank layout. 
 
Open up the Sports_hall.dwg file. 
 
You may need to display these tabs first:  Right click over the Model or Layout buttons in lower 
toolbar area and select Display Layout and Model tabs. See Section 2.3. 
 
Right Mouse Button click the Work or Layout1 layout tab next to the Model tab, bottom left of the 
display.  Select New Layout. To activate it click on the new layout tab and then Right Mouse 
Button click on it and Rename it A3plan.  
 
Right Mouse Button click on the new tab again and in Page Setup Manager…  Modify set paper 
size to A3 and make sure the plotting scale is set to 1:1, then click OK. 
 
You will now be looking at a default viewport showing what you have drawn in the model space. 
 
Erase this viewport.  You now have a blank A3 sheet with no viewports. 
 
 

http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/paperspace.wmv


6.4  Setting up the boarder. 
 
Start creating the presentation of your drawing on this layout by setting up the boarder.   
 
Insert the A3 boarder UoP_A3.dwg file as a block, Insert > Block > Browse… (for the 
downloaded UoP_A3.dwg file). Examine the layers now present in the drawing.  You should see 
new layers brought in by the boarder file, prefixed with the paper size, A3 in this case.  
 
Using the explode command explode this boarder block.  This enables you to edit the text, etc.  
 
Turn off the appropriate 1st/3rd angle projection layer, these two layers control the display of the 
projection symbol. 
 
6.5  Setting up a viewport. 
 
Now you will create a single viewport and re-size it to fit inside the boarder format. 
 
Create and make current a new layer called vp1 in the usual way.  Create a new viewport by 
doing this.....  
 
Pull down menu:  View > Viewports > 1 viewport 
Command line:  VPORTS 
 
In the display drag a rectangle on the layout to size to area of the paper you wish to use. 
 
You should now be viewing the model from the layout.   
 

 

Viewport, put 
on layer vp1. 
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You are viewing the layout in Paper Space.  To modify how the viewport shows the model, 
change the mode to Model Space.  Either click on the Model/Paper button, bottom of screen, use 
the mspace or pspace command in the command line, or double click inside the viewport for 
Model Space or outside the viewport for Paper Space. 
In model space you will see a heavy boarder around the viewport and the model space co-
ordinate system icon.  You can now use the usual pan and zoom features to control how the 
viewport displays the model, but only if you set the Display locked property to No.  Once you are 
happy with the view go back to paper space. 
 

 To set the scale that the viewport uses to view the model:   
Single click to select the viewport boarder. Activate its properties dialogue box either by 
clicking the properties toolbar button, or ‘right mouse button’ > properties or by running the 
properties command from the command line. 
 
Under the Misc header, set the scale you wish to use from the pull down menu of the 
Standard scale.  Alternatively you could enter a Custom scale or use the ZOOM command 
with the Scale option. Check out the Help for this. 
 
To lock this view, and therefore the scale setting, simply select Yes for Display locked. 

 
To stop displaying the viewport boarder simply turn off the vp1 layer. 
 
A viewport, remember, is an entity, just like a line or a circle is.  It has its own properties and you 
have now placed it on its own layer. You can set up as many different viewports as you wish. 
 
Edit the text in the title block appropriately and check that the projection symbol indicates the 
correct system of orthographic projection.  (See course notes.) 
 
Save your work.   
 
Note that when working on a layout sheet, in AutoCAD, you may find that linetypes are not 
displayed properly.  This may be because their size is being calculated relative to the paper size, 
not the model size.  So for this example you may need to change the LTSCALE to something like 
5 to see the dashed lines used to show hidden detail. 
 
You may also note that any text added to the layout uses sizes relating to paper size, not model 
size. 
 
6.6 Plotting. 
 
Here are some tips for plotting your prepared layout sheets. 
 

• It is probably best to plot in monochrome.  Right click the layout tab for the sheet you wish 
to plot.   To select a monochrome pen style: 

 
Page Setup Manager > Modify > Plot Style Table > monochrome.ctb 

 ….or similar 
• Always perform a Preview before sending to the plotter.   
• Check the appearance of the lines carefully.   
• Make sure that the line styles display correctly.   
• Make sure you have used appropriate line weights.  In the Layer manager I recommend 

setting the geometry outline line weights  to something like 0.3 to 0.5mm, and all centerlines 
and dimensions to 0.1 to 0.2mm.  See the course notes for guidance on this. 
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7  Finally...... 
 
With these basic draughting CAD skills you should now be able to create engineering drawings, 
fully dimensioned, annotated and presented on a standard paper size, using standard boarder/title 
blocks.  You should be able to control objects using layers and change the properties of each 
object using its own properties, create repetitive objects using blocks and perform various editing 
functions such as copying, trimming, etc. 
 
Using the AutoCAD help system you should now have a look at creating polylines, multilines, 
arcs, etc.  You should also examine some more editing commands such as scale, stretch, rotate 
and array. 
 
When you are familiar with these commands you could move on to the 3D tutorial. 
 
 
8  Summary of commands & video demonstrations: 
 
8.1  A quick summary of the basic commands used in this tutorial.  
 
Tool bars are also used. Right click in an empty toolbar area to configure. 
 
 
Command line: Key shortcut:  Pull down menu: 
 
CLOSE     File >   Close 
UNITS     Format >  Drawing Setup… 
LIMITS     Format >  Drawing Limits 
GRID   F7    Format >  Drafting Settings…    
SNAP   F9    Format >  Drafting Settings…    
ZOOM  Z          

Esc 
SAVEAS     File >   Save as… 
LINE      Draw >  Line 
COORDS 
SPLINE     Draw >  Spline 
ERASE     Modify >  Erase 
TRIM      Modify >  Trim 
OFFSET     Modify >  Offset 
EXTEND     Modify >  Extend 
OSNAP   F3 
LA 
XLINE      Draw >  Construction Line 
LTSCALE 
PROPERTIES    Modify >  Properties 
MOVE      Modify >  Move 
BHATCH     Draw >  Hatch 
BLOCK     Draw >  Block > Make 
INSERT     Insert >  Block… 
DIMSTYLE     Format >  Dimension Style… 
MTEXT     Draw >  Text 
VPORTS     View >  Viewports 
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8.2   Video demonstrations. 
 
List of video demonstrations, to be used in conjunction with the tutorial: 
 
Units, limits and grid > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/units_limits_grid.wmv 
 
Coordinates > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/coordinates.wmv 
 
Snap > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/snap.wmv 
 
Absolute & relative coordinates > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/abs-rel_coordinates.wmv 
 
Splines > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/splines.wmv 
 
Trimming & extending > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/trim_extend.wmv 
 
Offsetting > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/offset.wmv 
 
Object snap > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/osnap.wmv 
 
Layers > 
http://www.tech.plymouth.ac.uk/dmme/cad/wmv-2d-autocad/layers.wmv 
 
Linetype scale > 
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